Dog Site - Dog Stuff
Dog Forum | Dog Pictures

Go Back   Chazhound Dog Forum > Dog Forum News > Member Introductions


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-15-2012, 05:36 PM
Tednmeek Tednmeek is offline
Active Pup
 
Join Date: Nov 2012
Posts: 1
Default Puppy Question

I have a 15 week old bernese/mini labradoodle mix. At 10 weeks she started having a bunch of peeing accidents as well as peeing continuously when we went for a walk. Took her to the vet with urine sample. She had crystals (struvite) but no infection. The vet told me to augment her diet with Hills S/D. Because she is so young she did not want her to lose the nutrients of the puppy food I give her. So she gets kibble soaked in water with the Hills. After 2 weeks we tested her and the crystals were gone but an infection was now showing. Antibiotics were prescribed for 2 weeks. Tested and she had no crystals, no infection but elevated white blood cells so extended antibiotics for two weeks. Now she just went in for testing and her urine is basic and the crystals are back. Any suggestions? She is a great little puppy that wants to pee outside but still has accidents. The vet wants me to do a culture of her urine and go back on the Hills food along with the other food. I'm not sure what to do or what is causing this. Very frustrating. Does anyone have any suggestions?????
Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:00 AM.


1997-2013 Chazhound Dog Site